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IINTRODUÇÃONTRODUÇÃO

O Sublime Text é um editor de texto que foi projetado 

para ser simples, rápido, flexível e fácil de usar. Não é à 

toa que vem ganhando mais adeptos a cada dia, já que 

muitas vezes os programadores, escritores e usuários em

geral acabam cansados e frustrados por ter que lidar 

com IDEs pesadas e lentas ou editores de texto 

sobrecarregados de recursos que nunca vão precisar. 

Preparei este guia para quem está em busca de uma 

alternativa e quer aprender de maneira fácil e rápida os 

principais recursos que o Sublime Text tem a oferecer.

Nas próximas páginas, você será apresentado às 

funcionalidades mais importantes do Sublime Text e vai 

encontrar dicas que poderá incorporar ao seu uso diário.

Espero que você goste do que vai encontrar aqui. Se 

gostar, peço que compartilhe com seus amigos, para que 

eles também possam aproveitar as facilidades do 

Sublime Text.

Boa leitura!

Rodrigo Amaral

http://sublimetextdicas.com.br

http://sublimetextdicas.com.br/
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GGOTOOTO A ANYTHINGNYTHING

A maneira mais fácil e rápida de navegar entre arquivos 

no Sublime Text é usando o recurso conhecido como 

Goto Anything. 

Para ativá-lo basta digitar o atalho Ctrl+P.

Ao fazer isso, surgirá uma lista para que você possa 

escolher entre os arquivos abertos ou que fazem parte de

um mesmo projeto. Essa lista é filtrada à medida em que 

você digita o nome do arquivo que quer abrir.

Na prática, você vai fazer o seguinte:

1. Digitar Ctrl+P 

2. Começar a escrever o nome do arquivo que está 

procurando 

3. Selecionar o arquivo com as setas para cima ou 

para baixo 

4. Teclar Enter 

Note que o conteúdo do arquivo que estiver em destaque

é mostrado na tela, para facilitar sua identificação. 

Depois disso, tenho certeza que você vai se perguntar 

como conseguiu viver até hoje sem o Goto Anything.
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CCOMMANDOMMAND P PALETTEALETTE

Já imaginou se você pudesse fazer uma busca pelos 

comandos do editor do mesmo jeito que pequisa texto 

dentro de um arquivo?

O Sublime Text deixa você fazer isso com o recurso 

Command Palette. 

Com ele, você tem como pesquisar os próprios comandos

do Sublime Text por meio do atalho Ctrl+Shift+P.

O procedimento é similar ao do Goto Anything: ao 

acionar o comando, surge uma lista de seleção que é 

filtrada ao digitar os caracteres da descrição (em inglês) 

da funcionalidade que procuramos.

Aprendendo apenas esse comando, é possível encontrar 

praticamente qualquer funcionalidade, sem precisar 

navegar pelos menus ou decorar atalhos de teclado.

Então, não esqueça! Na dúvida, apele para o 

Ctrl+Shift+P.
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SSELEÇÃOELEÇÃO M MÚLTIPLAÚLTIPLA

A capacidade de selecionar trechos de texto de forma 

flexível é um dos recursos mais úteis do Sublime Text.

A seleção múltipla torna possível manipular texto 

usando mais de um cursor e mais de uma região 

selecionada. Falando assim pode não parecer, mas o 

número de diferentes situações nas quais o uso desse 

recurso nos poupa bastante tempo é surpreendente.

Para incluir linhas acima ou abaixo à seleção de texto 

atual, usamos Shift+Alt+Para cima ou 

Shift+Alt+Para baixo, respectivamente.

Perceba que cada linha incluída na seleção possui seu 

próprio cursor.

Quando selecionamos um trecho de texto (uma palavra, 

por exemplo), pressionar Ctrl+D faz com que a próxima 

ocorrência desse trecho também seja selecionada. Do 

mesmo modo, um cursor é criado na posição 

correspondente.



Guia Rápido do Sublime Text – http://sublimetextdicas.com.br    |     8 

VVISUALIZAÇÃOISUALIZAÇÃO  DADA I INTERFACENTERFACE

Na primeira vez que usei o Sublime Text, fiquei 

impressionado com o seu visual limpo. Levei um tempo 

para me familiarizar e fui descobrindo como fazer para 

deixar a interface de acordo com minhas preferências. 

No menu View encontramos a maioria das opções de 

visualização mais importantes. Nesse menu podemos 

habilitar e desabilitar a barra lateral (View > Sidebar > 

Show/Hide sidebar), as abas dos arquivos abertos (View >

Show/Hide tabs), a barra de status (View > Show/Hide 

status bar), o mini-mapa (View > Show/Hide minimap) e o

console de linha de comando (View > Show/Hide 

console).

O Sublime Text também possui um recurso muito útil 

para quem precisa se concentrar quando está 

escrevendo um texto. Digitando Shift+F11 você aciona 

o modo sem distrações (distraction-free mode) do editor, 

cuja função é remover da sua tela tudo o que não for a 

área de edição de texto.

Para mim funciona que é uma beleza, vale a pena 

experimentar!



Guia Rápido do Sublime Text – http://sublimetextdicas.com.br    |     9 

OOPÇÕESPÇÕES  DEDE L LAYOUTAYOUT

O Sublime Text permite que você organize seus arquivos 

abertos em várias disposições na tela. Você pode agrupá-

los em colunas, linhas ou em formato de grade. Essa 

funcionalidade é muito útil quando trabalhamos com 

arquivos que são relacionados entre si. Imagine 

visualizar uma página HTML e sua respectiva folha de 

estilos CSS em colunas lado a lado, por exemplo.

Para fazer isso, vá em View > Layout > Columns: 2 (ou use

o atalho Alt+Shift+2). Será criada uma nova coluna 

para o qual podemos arrastar qualquer aba de arquivo 

aberto ou movê-la por meio do atalho 

Ctrl+Shift+<número_do_grupo> (no caso, 

Ctrl+Shift+2).

Os layouts possíveis são:

• 2, 3 ou 4 colunas (Alt+Shift+<2, 3 ou 4>)

• 2 ou 3 linhas (Alt+Shift+<8 ou 9>)

• Grade 2 x 2 (Alt+Shift+5)

Para retornar ao layout de painel único, basta digitar 

Alt+Shift+1.



Guia Rápido do Sublime Text – http://sublimetextdicas.com.br    |     10 

CCONFIGURAÇÃOONFIGURAÇÃO  DEDE P PREFERÊNCIASREFERÊNCIAS

Uma coisa que os recém-chegados ao Sublime Text 

estranham é a falta de uma tela de configuração de 

preferências. No Sublime, essa configuração fica 

armazenada em um arquivo texto, em formato JSON, que

pode ser encontrado em Preferences > Settings – Default.

No entanto, como o nome diz, essas são as configurações 

padrão. Se você precisar fazer algum ajuste nas suas 

preferências, deve incluir apenas as modificações 

desejadas no arquivo de preferências do usuário, que 

está em Preferences > Settings – User.

Por exemplo, para mudar a fonte do texto, basta apenas 

copiar a linha "font_face": "", do 

Default/Preferences.sublime-settings para o  

User/Preferences.sublime-settings substituindo 

pelo nome da fonte desejada (ex.: "font_face": 

"Ubuntu Mono"). Dessa forma fica fácil mover as 

preferências do usuários entre diferentes instalações do 

Sublime.

O arquivo default vem com muitos comentários que 

explicam para que serve e como funciona cada 

configuração.
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TTECLASECLAS  DEDE A ATALHOTALHO

Da mesma forma que a configuração de preferências, os 

atalhos de teclado do Sublime Text também são definidos

em um arquivo texto no formato JSON.  Do mesmo modo,

também existe um arquivo de configuração default 

(menu Preferences > Key Bindings - Default) e outro com 

as preferências de atalhos de teclado do usuário (menu 

Preferences > Key Bindings – User).

Essa flexibilidade é necessária para permitir a 

arquitetura que torna o Sublime Text um editor tão 

extensível. Mesmo as funcionalidades mais básicas - 

como copiar e colar, por exemplo - são implementadas 

por meio de comandos, que por sua vez podem ser 

mapeados para serem disparados por uma combinação 

de teclas.

Outra vantagem é que descobrir os atalhos de teclado é 

muito mais fácil: basta abrir o arquivo de configuração 

padrão e procurar pelo nome do comando que se deseja 

saber a tecla de atalho1.

1 Mais detalhes sobre atalhos em http://bit.ly/TRHjAb 

http://bit.ly/TRHjAb
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PPROJETOSROJETOS

Quando você precisa trabalhar com vários arquivos 

abertos ao mesmo tempo, o melhor a fazer é agrupá-los 

em projetos.

No Sublime, um projeto é a informação que o editor 

armazena sobre um conjunto de arquivos relacionados 

entre si2.

Para criar um projeto, adicione uma ou mais pastas com 

a opção Project > Add folder to project... Fazendo isso, 

todas as pastas e arquivos adicionados passam a estar 

“sob controle” do Sublime e recursos como o Goto 

Anything e a busca avançada passam a funcionar para 

esses arquivos.

Para salvar o projeto, vá em Project > Save project as... O 

Sublime pedirá que você informe o nome do arquivo do 

projeto, que deve ter a extensão .sublime-project.

Para abrir um projeto salvo, selecione Project > Open 

Project... e em seguida o arquivo de projeto desejado. 

O atalho Ctrl+Alt+P abre uma caixa de seleção rápida 

para os projetos recentemente acessados.

2 Aprenda sobre organização de projetos em http://bit.ly/1whpXva 

http://bit.ly/1whpXva
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BBOOKMARKSOOKMARKS

Tenho certeza de que um dia você já precisou editar 

arquivos bem extensos, certo? Então você sabe como 

pode ser irritante alternar entre dois trechos de texto ou 

código-fonte que ficam distantes um do outro.

Para facilitar sua vida, o Sublime Text oferece o recurso 

de bookmarks. Criar um bookmark em um determinado 

ponto do arquivo facilita a navegação até ele por meio de

teclas de atalho.

Para criar um bookmark, basta posiciona o cursor na 

linha desejada e digitar Ctrl+F2. A mesma combinação 

de teclas serve para remover o bookmark.

A navegação é feita por meio dos atalhos F2 (para 

avançar ao próximo) e Shift+F2 (para retornar ao 

anterior).  Ctrl+Shift+F2 remove todos os bookmarks 

do arquivo.
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IINSERÇÃONSERÇÃO  DEDE L LINHASINHAS

Uma operação muito frequente quando estamos 

editando código-fonte é a inserção de linhas abaixo ou 

acima da linha onde está o cursor. 

Você há de concordar que é um aborrecimento mover o 

cursor até o início ou final da linha, teclar Enter e 

mover o cursor para a linha acima ou abaixo, correto?

No Sublime Text você faz todos essses passos com apenas

uma combinação de teclas:

• Inserir linha abaixo: Ctrl+Enter

• Inserir linha acima: Ctrl+Shift+Enter

Depois é só sair digitando, pois o cursor já vai estar no 

lugar certo.

Pode parecer bobagem, mas esse é um dos atalhos de 

teclado que mais vale o investimento de adquirir o 

hábito de usar.

Experimente!
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RREMOÇÃOEMOÇÃO  DEDE T TEXTOEXTO

Da mesma maneira que a inserção de novas linhas, 

apagar texto a partir da posição do cursor até o início ou 

o final de uma linha, por exemplo, pode ser bem 

trabalhoso. Selecionar o trecho de texto desejado envolve

uma sequência de movimentos que pode ficar 

relativamente complicada.

Mais uma vez, o Sublime vem ao resgate com alguns 

atalhos de teclado preciosos:

• Apagar texto da posição do cursor até o início da 

linha: Ctrl+Shift+Backspace

• Apagar texto da posição do cursor até o final da 

linha: Ctrl+K, Ctrl+K (isso mesmo, Ctrl+K duas 

vezes)

• Apagar palavra anterior: Ctrl+Backspace

• Apagar palavra seguinte: Ctrl+Del 

O segredo para se habituar aos atalhos é tentar pensar 

duas vezes antes de selecionar um trecho de texto. Se sua

intenção é apagá-lo, lembre-se deles!
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MMANIPULAÇÃOANIPULAÇÃO  DEDE T TEXTOEXTO

Vamos falar um pouco sobre como movimentar e 

transformar trechos de texto. Como você já sabe que 

para ser produtivo deve-se evitar ao máximo tirar as 

mãos do teclado, vamos a mais alguns preciosos atalhos.

Para mover um grupo de linhas para cima ou para 

baixo, basta selecionar as linhas e digitar 

Ctrl+Shift+Up ou Ctrl+Shift+Down, respectivamente.

Mas atenção que agora vem a parte boa e 

importantíssima: para mover uma única linha, não 

precisa selecionar antes. Basta o cursor estar 

posicionado nela.

E se eu quiser duplicar uma linha já existente? Fácil! O 

atalho para isso é Ctrl+Shift+D (“D” de duplicar, para 

não esquecer) na linha que deseja duplicar. Certamente 

você já deve ter deduzido que, para duplicar um bloco de

linhas, é só selecioná-lo antes.

Para finalizar, se você precisar colocar todo o texto 

selecionado em caixa alta rapidamente, basta fazer um 

Ctrl+K, Ctrl+U. Para transformar em caixa baixa, 

faça Ctrl+K, Ctrl+L.
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OORDENAÇÃORDENAÇÃO  DEDE L LINHASINHAS

Quem nunca precisou colocar as linhas de um arquivo 

texto gigantesco em ordem alfabética?

No Sublime Text é só digitar F9. Pronto.

Se quiser diferenciar maiúsculas e minúsculas, dê um 

Ctrl+F9.

Além dessas opções, no menu Edit > Permute lines > 

Reverse você pode trocar a ordem das linhas 

selecionadas (a primeira passa a ser a última, a segunda 

vira penúltima e assim por diante).

Outro recurso interessante é que com a opção  Edit > 

Permute lines > Shuffle você pode ordenar 

aleatoriamente as linhas do arquivo. 

Ou seja, o Sublime Text vem com um “sorteador” pronto 

para usar!

Por fim, se você precisar eliminar linhas repetidas em 

um arquivo, basta usar  Edit > Permute lines > Unique. 
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BBUSCAUSCA  DEDE T TEXTOEXTO

Depois de tantos recursos surpreendentes, é claro que o 

Sublime não iria deixar por menos na hora de pesquisar 

texto. 

Além do tradicional e onipresente Ctrl+F, para localizar

a primeira ocorrência do texto após o cursor, o editor 

traz mais alguns truques na manga:

Ctrl+H faz a pesquisa e substituição do texto. Tanto ele, 

quanto a busca normal abrem um painel de busca com 

várias opções, entre elas a busca usando expressões 

regulares.

Ctrl+I é semelhante à busca normal, mas se restringe 

apenas à primeira ocorrência. Ao digitar Enter, o painel 

some.

Mas, para mim, a grande estrela da busca e substituição 

é o Alt+F3. Esse danado tem a manha de encontrar e 

selecionar todas as ocorrências da palavra sob o cursor 

–  ou do texto selecionado – criando um cursor após cada 

uma delas. Daí é só apagar, inserir ou modificar texto à 

vontade: tudo o que você digitar se repete ao mesmo 

tempo para cada ocorrência!
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EESQUEMASSQUEMAS  DEDE C CORESORES

O esquema de cores padrão do Sublime Text é muito 

bonito, mas ainda assim é possível que a pessoa tenha 

outras preferências ou simplesmente queira variar de 

vez em quando.

No item de menu Preferences > Color Scheme é possível 

escolher entre mais de 20 esquemas de cores. Dê uma 

olhada neles e veja se tem algum que te agrada mais.

Além disso, também é possível, instalar novos esquemas 

de cores disponíveis online, personalizar um esquema 

existente ou até mesmo criar o seu próprio do zero.

Os detalhes da criação de esquemas de cores estão além 

do escopo deste material, mas se você estiver curioso 

para saber qual o jeitão de um arquivo de definição de 

esquema, vá em Preferences > Browse package, entre na 

pasta Color Scheme – Default, e abra algum dos 

arquivos do tipo .tmTheme.



Guia Rápido do Sublime Text – http://sublimetextdicas.com.br    |     20 

MMAISAIS D DICASICAS  DEDE S SELEÇÃOELEÇÃO  DEDE T TEXTOEXTO

Como você faz quando precisa selecionar uma linha? Vai 

até uma de suas extremidades com Home ou End, depois 

segura o Shift e aperta End ou Home? Ou pior, tira a 

mão teclado e usa o mouse?

No Sublime Text, para selecionar uma linha basta digitar 

Ctrl+L.

Se quiser selecionar somente a palavra sob o cursor, 

basta um Ctrl+D.

O atalho Ctrl+Shift+Espaço, por sua vez, faz algo 

interessante, que é selecionar todo o escopo que contém 

o cursor. Para facilitar o entendimento, em arquivos de 

texto, esse comando seleciona um parágrafo.

Por fim, temos o Ctrl+Shift+L, que pega a área de texto

selecionada e divide essa seleção em linhas, para as 

quais é criado um cursor para cada. Muito útil quando 

precisamos adicionar o mesmo texto em várias linhas 

consecutivas, por exemplo.
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AALGUMASLGUMAS C CONFIGURAÇÕESONFIGURAÇÕES Ú ÚTEISTEIS

Já que a configuração de preferências do Sublime Text 

fica um pouco escondida nos Preferences.sublime-

settings, vale a pena conhecer algumas opções básicas 

que não aparecem nos itens de menu.

Lembre-se de copiar as linhas correspondentes à opção 

desejada para o arquivo  de preferências do usuário, que 

está em Preferences > Settings – User, e lá modificar os 

valores.

font_face Muda a fonte na qual o texto é mostrado

line_numbers Habilita/desabilita a contagem de linhas

gutter Habilita/desabilita exibição da margem

caret_style Muda o estilo do cursor

save_on_focus_lost
Salva os arquivos automaticamente ao 
alternar para outro aplicativo

copy_with_empty_selection
Quando nada está selecionado, Ctrl+C 
copia toda a linha na qual o cursor está 

preview_on_click
Mostra conteúdo do arquivo selecionado 
na barra lateral sem abri-lo

show_full_path
Mostra na barra de título o caminho 
completo do arquivo aberto 

hot_exit
Modificações não salvas são preservadas 
ao sair do Sublime e restauradas 
automaticamente ao voltar

drag_text
Permite arrastar e soltar texto 
selecionado

tab_completion Aciona o autocompletar com Tab

highlight_line Destaca linha na qual o cursor está
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SSNIPPETSNIPPETS

Snippets são trechos de código ou texto prontos para 

inserção em qualquer ponto de um arquivo por meio de 

um trigger (gatilho) acionado pela tecla Tab.

Vou dar um exemplo na prática.

Experimente digitar a palavra “lorem” seguida da tecla 

Tab em uma janela de edição. “lorem” é o trigger que 

serve para inserir um parágrafo com o famoso texto 

“Lorem ipsum dolor sit amet…”, usado para preencher 

textos de exemplo.

Para ver os snippets disponíveis para o contexto da 

sintaxe do arquivo que você está editando, basta 

selecionar a opção Tools > Snippets… no menu.

Como não podia deixar de ser, também é possível criar 

nossos próprios snippets personalizados3. Para isso, é só 

selecionar a opção de menu Tools > New snippet….

Agora você já sabe o que fazer para economizar 

digitação quando precisar daquele trecho de código que 

você nunca lembra direito.

3 Mais sobre snippets em http://bit.ly/TRrJEA 

http://bit.ly/TRrJEA
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PPACOTESACOTES  EE P PLUGINSLUGINS

Um pacote é uma pasta que contém arquivos de 

configuração ou scripts que  servem para estender as 

funcionalidades do Sublime Text. Ele organiza os 

arquivos necessários para implementar um recurso4. 

Os recursos que um pacote implementa podem ser 

configurações, temas, definições de sintaxe, esquemas de

cores, mapeamentos de teclas ou qualquer outro tipo de 

componente personalizável do Sublime.

Na prática, as pastas com os arquivos são distribuídas na 

forma de arquivos compactados no formato zip e com a 

extensão .sublime-package.

Pacotes também são a maneira de armazenar os plugins5,

que são o coração dos superpoderes de extensibilidade 

do Sublime Text.

Para ver onde ficam os pacotes em sua instalação vá em 

Preferences > Browse packages.

4 Detalhes sobre pacotes em http://bit.ly/1hayYln 
5 Saiba mais sobre criação de plugins em http://bit.ly/1oGxxep 

http://bit.ly/1oGxxep
http://bit.ly/1hayYln
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GGERENCIADORERENCIADOR  DEDE P PACOTESACOTES

Package Control é o primeiro plugin que você precisa 

instalar no seu Sublime Text. Ele é um é um gerenciador 

dos pacotes instalados e sua função é facilitar a 

descoberta, instalação e atualização desses pacotes.

Para instalar6, acesse o console do Sublime, por meio do 

atalho Ctrl+' ou do menu View > Show Console. Com o 

console aberto, vá em http://sublime.wbond.net/installation,

copie o código que está lá, cole no console e digite Enter.

Reinicie o Sublime Text para completar a instalação.

Você poderá ver as ações relacionadas ao gerenciador de 

pacotes acionando o Command Palette com 

Ctrl+Shift+P. Depois, comece a digitar “package 

control” na caixa de texto e você verá a lista de 

comandos disponíveis7.

O Package Control busca os pacotes em um repositório 

no qual os autores de plugins, temas e demais 

componentes do Sublime disponibilizam suas criações.

Tire um tempinho para vasculhar os pacotes disponíveis 

e surpreenda-se! 

6 Detalhes da instalação do Package Control em http://bit.ly/1oGZUce 
7 Conheça os comandos em http://bit.ly/1mBm1QM 

http://bit.ly/1mBm1QM
http://sublime.wbond.net/installation
http://bit.ly/1oGZUce


Você está pronto para aprimorar ainda mais
suas habilidades no Sublime Text?

Para você não perder tempo, preparamos uma newsletter mensal com 
conteúdo exclusivo e cuidadosamente selecionado. São dicas de uso, 
sugestões de plugins e tudo sobre os principais recursos do Sublime Text!

Este ebook cobre apenas as noções básicas sobre as principais 
funcionalidades e características do Sublime Text. Mas, isto é só o 
começo...

Para ganhar familiaridade com o editor de texto e conseguir extrair o 
máximo de suas funcionalidades, acompanhe os posts no site e siga a 
gente nas redes sociais:

 /SublimeTextDicas /stdicas /+SublimeTextDicasBr

Mas se quiser saber das novidades em primeira mão, fica a dica: nós 
publicamos todo nosso conteúdo antes na newsletter. Então...

http://plus.google.com/+SublimetextdicasBr
http://twitter.com/stdicas
http://facebook.com/SublimeTextDicas
http://sublimetextdicas.com.br/
http://assine.sublimetextdicas.com.br/
http://assine.sublimetextdicas.com.br/

